Please Disable Ad-Block To View This Website.

If you block ads, this site can not survive!

Ads are very minimal for registered users. If you don't have an account please register now!

DOWNLOAD
 Full Scripts
 Addons
 Snippets
 DLLs
 MTS Themes
 Tutorials
 Misc.
 File Queue
 Download mIRC
INTERACT
 Screenshots
 Challenge
 Top Downloads
 Submit Form
 Forums

SEARCH
Site Search

FRIENDS
Link to us!
PhotoShelf

Home | Comments:
Average Rating:   9   weather client (INTL) v4.2 by []DLAST|C
Description:
A neat little addon that retrieves US and international weather information.

Submitted Review Author's Updates

There is no review for this file yet.
Full history of changes at http://plastic.xsintrk.net/mirc/weatherclient/vhist.txt

4.0 [01/24/2006]
- Completely re-written.

4.1 [08/15/2007]
- Added check for $decode lock/unlock while loading.
- Changed version check code.
- Include default search in 'Check weather' dialog.

4.2 [09/09/2007]
- Added ON INPUT event so the local user can use !weather trigger.
- Added /weather command flag descriptions to the 'Check weather dialog'.
Screenshot:

Comments:

  Mode:    Create New Post

startmeupNov 16, 2011 4:55AM
Weather has stopped working recently. I have no idea why. Have tried other saved working versions and get the same result..

[04:43] <start-me-up> dstmagnet: From
[04:43] <start-me-up> sunrise/sunset(/) moonrise/moonset(/) moonphase()
[04:43] <start-me-up> :

Something has changed. I can tell you that it is hands down the best weather reporter there is, please fix it. I have been using it for a few years and it has worked flawlessly. please see what you can do to fix it!!!

FervantLagZillaNov 22, 2011 7:52PM
Yes, this has happened to me also. It stopped working for me last wednesday night (nov. 16th)
[18:48:51] <BotZilla> SpaceZilla: From
[18:48:51] <BotZilla> sunrise/sunset(/) moonrise/moonset(/) moonphase()
[18:48:51] <BotZilla> :

I havent the foggiest idea why it quit, but nothing i do seems to matter.



"it is hands down the best weather reporter there is, please fix it. "
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

ScottKNov 23, 2011 1:28AM
Ditto on that!

The problem appears to be the new xml / xaml schema that Weather Underground is using.

So, PLEASE oh PLEASE fix this awesome script!

--ScottK

jeffpNov 25, 2011 1:45AM
until an update is available, you can delete line 312 in weatherclient.mrc (the Accept-Encoding header) to get the script working again. nice surprise to see some ppl still using this old addon.

roaddirtNov 25, 2011 11:34AM
Thanks jeffp! I had already deleted my weather script because I'd given up hope. I reloaded it after seeing your post and deleted line 312 and it works great again! Thanks a bunch dude!!!!

startmeupNov 25, 2011 2:24PM
thank you sir..works fine again...and yes...its a great lil snippet

jeffpNov 25, 2011 3:31PM
yw guys.

ScottKNov 26, 2011 6:17PM
Massive thanks, Jeff!! I use this script for the channel associated with our IRC Network's Streaming Audio service, and it meshes pefectly with how we run the channel.

KUDOS, Jeff!

--ScottK

FervantLagZillaNov 29, 2011 11:20PM
Most excellent! You have NO IDEA how happy it makes me to go into chat and use the trigger to find out EVERYTHING I want to know about the current weather and the forecast for the day, instead of having to go through MANY steps to see this same info from a webpage! Thank you for telling us how to fix this!

Shannons69Dec 8, 2011 11:41PM
Thank you - Thank you ---- THANK YOU Jeff!!!!!!!!!!!!!!!!!!! :P:P:P:P:P

You have nooooooooooooooo idea how happy you made me. ;) I have been using this little add-on for quite a few years now (like six or something :$) and was crushed when it stopped working. :$ Now I can check my 'temp again' to my hearts content..

Seriously -- Thanks for your time in figuring out what was wrong.... YOU ROCK :D

Shannon

rvdoctorDec 9, 2011 12:04PM
hey what is line 312 mine dont go by numbers or im to green to figure it out or has a update been put out mine does the same as posted just started 3 days ago
thanks for the help keith

Shannons69Dec 9, 2011 9:59PM
Keith,

This is the line I took out of mine..

wc.sockwrite -n $sockname Accept-Encoding: gzip, deflate

In mine it was line 313 - Most versions of mIrc show line numbers in scripts editor..
Or you could use Notepad ++ (Open source-Freeware) from http://notepad-plus-plus.org/


Shannon

rvdoctorDec 10, 2011 9:54PM
Shannon
thanks for your help your a life saver my mirc editor dont give # but you can reqest line 312 and it worked than for the tip
have a great day
keith

roaddirtMar 21, 2012 8:09PM
It's looking like the weather script has developed another problem. It's reporting all the current conditions just fine. As for the forecast all I'm getting now is : and nothing else.

GreyVulpineMar 27, 2012 8:28AM
Change line 365 from:

if (*<b>Forecast as of*</b>* iswm %w.buf) { set $+(%,$sockname,fc) 1 }

to:

if (*Forecast as of*</b>* iswm %w.buf) { set $+(%,$sockname,fc) 1 }


roaddirtMar 28, 2012 7:34AM
Thank you GreyVulpine!

It's working like a charm again :))

FervantLagZillaApr 23, 2012 11:15PM
Thank God someone still pays attention to mircscripting!This is twice now in the last few months that the script has stopped working correctly. It was actually line #364 in my editor, no clue why, but meh!; you supplied the old syntax, and i was able to find it that way! Thanks man!

EvilHom3rAug 12, 2007 10:54AM
Rating:     8i like this scrpit, just could you fix it so it works on mirc 6.21 properly? Becuse im trying to use it on that and its not working. It worked for like 5 seconds, and now it wont work.

[]DLAST|CAug 15, 2007 6:32PM
Yes, I'll see what I can do asap. Strange that it doesn't work for you.

Edit - hope the update works better for you. Please delete your old script and INI before loading this one.

Text edited by author on Aug 15, 2007 @ 7:57PM


EvilHom3rAug 16, 2007 9:03PM
Odd, still dosent work.
I just noticed that when if i set my options, click ok, then reopen options none of them are there. :(

[]DLAST|CAug 16, 2007 10:15PM
I don't see how it's possible. Check your pmsg from me and let's see if we can solve it.

KoukinJul 26, 2008 8:23AM
got the same prob.. but i already knew the answer..

its vista ... and the admin prob

well .. just go to ur irc shortcut.. right click .. options... compatibility and check ur "run program as admin" or something like that..

cant tell u the real english names.. got the german vista version ^^"

well gl & hf.. btw ty for this addon

[]DLAST|CJun 5, 2008 9:39PM
I am no longer hosted by xsintrk.net for reasons unspecifed and without notice. My apologies to those who used my website!

bbeApr 2, 2008 12:10AM
Hi, great script

I was trying to customize the theme but ran into some trouble. I have 2 questions:

Firstly, how can I remove the space between temperature and Celsius? (9C instead of 9ÂșC or 9 C)
Secondly, how can I change '4:50a Apr 02 08' back to wundergrounds '4:50 AM BST on April 02, 2008'?

http://mobile.wunderground.com/cgi-bin/findweather/getForecast?brand=mobile&query=edinburgh+uk

INI Output:
$wc($1).ob ( $+ $wc($1).up $+ ) Temperature: $wc($1).temperature ( $+ $wc($1).windchill $+ ) Humidity: $wc($1).humidity Dewpoint: $wc($1).dewpoint Wind: $wc($1).wind Conditions: $wc($1).conditions Sunrise/Sunset: $wc($1).sunrise $+ / $+ $wc($1).sunset
-->
Edinburgh, United Kingdom (4:50a Apr 02 08) Temperature: 6 C (3 C) Humidity: 87% Dewpoint: 4 C Wind: SW at 15 kph Conditions: Clear Sunrise/Sunset: 6:40 AM BST/7:54 PM BST

:)

[]DLAST|CApr 5, 2008 6:48PM
Those things are hardcoded in the script. I can't tell you offhand how to change them, sorry.

Text edited by author on Apr 9, 2008 @ 3:53AM


GreyVulpineJun 25, 2007 2:44PM
Edit: nm, found the problem.

-GV

Text edited by author on Jun 25, 2007 @ 3:20PM


WeatherUserMar 14, 2007 8:34AM
Rating:     9Is it possible to request personal weather stations in mIRC so for example i request !weather london weather center and London, London United Kingdom is the default station, but i want Forest Hill United Kingdom to come up in mIRC, is this possible? or is it possible to make this happen? Please, and thank you

[]DLAST|CMar 18, 2007 6:09PM
You want it to show weather for Forrest Hill instead of London? I don't see Forrest Hill UK on wunderground. So nup :(

morkyDec 16, 2006 11:49AM
Rating:     9pretty nice... thanks man

terseOct 5, 2006 12:44AM
Weatherclient 4.0 hasn't worked for me since I upgraded to mIRC 6.2. When I try to trigger the weather nothing at all happens, not even an error message popup.
Am I correct in assuming that WeatherClient is not compatible with mIRC 6.2?
Are there any plans for upgrading?
And, if it's supposed to work where can I find a list of those 5 digit International Station ID's?

I really miss my WeatherClient.

Thank You,
Dennis

[]DLAST|COct 8, 2006 2:05AM
Hi terse, try reinstalling it - it will give a warning that it's only been tested on 6.16, but it should work fine. I don't know why it stopped working after your upgrade.

The only way I know to get the intl station ID is to search for the city using http://mobile.wunderground.com and then take the ID from the webpage name (ex http://mobile.wunderground.com/global/stations/03140.html). A '/weather -s 03140' should return weather conditions for Glasgow UK.

Help000Mar 28, 2006 8:21AM
Rating:     10Hey, thanks for the great work, just got a question: How would i get Wind Gust to show up when requesting weather?

[]DLAST|CMar 28, 2006 10:56PM
Hello, I don't think gust info is available on mobile.wunderground.com.

pillowfightJan 21, 2006 9:57PM
In version 3.2 I'm getting this for every single weather search.
[21:45:36] <acfgdrfdsew> !weather 32612
[21:45:38] <pillowfight> acfgdrfdsew: bad search param or no results.

Version 4.03a gives me weather results, but I end up getting flooded by 'W.TRIG Unknown command' in my server window. Also, the city names are completely different when using the observation stations. They're not even the same as on wunderground.com. For example:
[21:40:17] <quackk> !weather buttzville
[21:40:18] <pillowfight> quackk: From Somerville, New Jersey (8:53p Jan 21 06) temp(41 F, feels like 35 F) cond(Partly Cloudy) wind(NW at 9 mph) hu(53%) dewpnt(25 F) bp(30.34 in) clouds((FEW) : 4700 ft) vis(10.0 miles)

The last one is minor and I can deal without it, but the flooding and the bad search param are becoming rather annoying.
Thanks for any help you might be able to offer.

[]DLAST|CJan 22, 2006 4:20AM
quote:
In version 3.2 I'm getting this for every single weather search.
[21:45:36] <acfgdrfdsew> !weather 32612
[21:45:38] <pillowfight> acfgdrfdsew: bad search param or no results.
Confirmed, I guess the page changes broke it. I'll start getting 4.0 ready to release here.
quote:
Version 4.03a gives me weather results, but I end up getting flooded by 'W.TRIG Unknown command' in my server window. Also, the city names are completely different when using the observation stations.
You need to unload 3.2, there is no 'w.trig' command in 4.0. Again, there's nothing I can do about the city names for now. If it bothers you, stop showing the observation station.

pillowfightJan 22, 2006 12:58PM
I had changed the name of 3.2 in order to see if it work work again in the future. Now it's completely gone, with 4.0rc1 installed, and it's working fine. Thanks.

[]DLAST|CJan 22, 2006 9:50AM
Here's the Weather client 4.0 release candidate. If no problems are discovered with the RC it will be submitted here later this week.

Text edited by author on Jan 22, 2006 @ 9:52AM


Zee11Jan 18, 2006 6:15PM
The location isn't coming up anymore

So for example you'd type !weather paris france and the forcast would come up but the location doesn't

Is there a fix to this please?

Any new updates to the maker of this program ?

[]DLAST|CJan 19, 2006 10:24PM
City info isn't on the mobile.wunderground.com pages anymore so replace <city> with <obs> in v3.2, or $wc($1).ci with $wc($1).ob in v4.0a. I will fix this in Weather client when/if it is fixed on the pages.

zkat2Sep 18, 2005 10:49PM
I love this script!! I'm a n00b and got it working 'cept that it will not display the result of my query in the channel. When others do !weather 75056, for example, it displays in channel but it won't when I do it. Also, for me to see a result (and only I can see it) I have to use /weather 75056. Is that correct?
Is there any way I can make MY query show in the channel?
Thank you for your work on this and for sharing it!!

[]DLAST|CSep 20, 2005 2:17AM
Thank you, I hope you're using the alpha version :) What you are trying to do isn't possible in mIRC because it doesn't catch your *own* text, only that which comes from the server. The only workaround I can think of would be to run it from a different mIRC (or used multiserver and put the bot on a different connection). Sorry!

hixxyOct 11, 2005 6:19PM
Or use the on input event.

[]DLAST|COct 12, 2005 7:29AM
Won't happen :)

IcyLiquidDec 23, 2005 4:28PM
Get with the times, plastic :p

on *:text:*:#:{ 
  focus.weather.triggered pub $network $chan $nick $1 $$2- 
}

on *:input:#:{ 
  if (!$ctrlenter) { focus.weather.triggered self $network $chan $me $1 $$2- } 
}


gliXDec 3, 2005 9:14AM
Great script. It works for me, but what do I type in display to receive forecasts?

[]DLAST|CDec 21, 2005 6:31PM
in 4.0a3 put:
quote:
$wc($1,1).fcd : $wc($1,1).fci
$wc($1,2).fcd : $wc($1,2).fci
$wc($1,3).fcd : $wc($1,3).fci
ect.. or format it however you want.

gliXDec 22, 2005 7:26PM
works thanks. is there a way i can get it to display forecasts from a separate trigger like !forecast <zip>
instead of having it display the forecast AND weather when u say !weather <zip>

it would probably work if i loaded the script twice and used one for each, but is there an easier way?

Text edited by author on Dec 22, 2005 @ 7:27PM


[]DLAST|CDec 23, 2005 1:37PM
No, but I'll try to write a signal script to do it since a few people have asked.

ovelayerDec 3, 2005 10:56AM
this script is totally phat and i have found no errors at all!! i am using weatherclient4.0-a03
one thing alot of request's that a second trigger be made to just display the forcast and alet's
so if i did !forcast zip it would display the forcast and alert for that zip
other then that hell of a job this script rocks!

[]DLAST|CDec 21, 2005 6:29PM
Hi, thanks for the suggestion. I'm glad you haven't found errors :)

X_FilesDec 12, 2005 11:53PM
A simple request for 403a, people get annoyed, everyone is running these scripts these days, and this issue of spamming a channel is becoming more of a problem then i thought. I have tried to click on send via notice, it absolutly refuses to do so. It will send via msg to channel, which of course everyone see's, and thats what annoys them. I am in an aweful lot of channels and an aweful lot of folks have this script, or others, and sometimes 20 people will flood the channel with their data. Good grief! Anyways, thats all i got to say.

[]DLAST|CDec 21, 2005 6:20PM
If you want private notices, tell your friends to use /notice <nick> <trigger>, because the bot replies by the same method it was triggered. You can also uncheck 'reply by msg' and 'allow in channels' to enforce this. Thanks for using my script :)

[]DLAST|CAug 8, 2005 4:13AM
A third 4x alpha is available at http://plastic.xsintrk.net/mirc/weatherclient/4x/prev/weatherclient4.0-a03.zip. Please test, and let me know here if you have problems. Thank you.

[]DLAST|CSep 14, 2005 12:55PM
bump

C420DoggSep 7, 2005 12:30PM
hi love the program. get more results than others i tried.
one little thing however is the way the weather is displayed. i was hoping you could tell me how to make it display in the chan for all to see instead of a notice or priv msg.

[]DLAST|CSep 14, 2005 12:54PM
If you do the !trigger <zip> in a channel, it should reply to the channel. If you are using ver 3.2 I think the command to use /msg is '/wsendtype msg', if you are using the 4.0 test go to Options>Bot and set it there.

Help000Feb 26, 2005 8:39AM
This is EXCELLENT! The best version yet, but Humidity is not showing up, any ideas?

Help000Feb 26, 2005 8:44AM
oh yes one more thing "Feels like" doesn't show up for American zip codes but if you do like !weather lhr it does ... odd?

[]DLAST|CFeb 26, 2005 6:55PM
I forgot to include humidity, that's fixed now. Thank you.
Yeah they don't seem to calculate windchill for any US cities, and not even all the International ones :/

quiglagJul 18, 2005 2:12PM
Im using weatherclient40a02 but humidity doent seem to work. I see that it is written in the script, so maybe a bug or typo?

[]DLAST|CAug 15, 2005 1:46AM
Works fine for me, try with the new version

[]DLAST|CFeb 25, 2005 12:16AM
A second alpha release is available athttp://plastic.xsintrk.net/mirc/weatherclient/4x/. I encourage everyone to test, give opinions, whatever.

Help000Feb 20, 2005 10:12AM
Hi, i love your work, as i've said i use this ALL THE TIME, but we use this in a really popular channel and sometimes 10 people at a time request weather, is there any way to make
v4.0 display the weather v3 does, v4 floods the room.? And does it display windchill? Thanks :)

[]DLAST|CFeb 20, 2005 4:15PM
quote:
is there any way to make v4.0 display the weather v3 does, v4 floods the room.?
Edit the output stuff in wtest.ini (//run $wc.ini).
quote:
And does it display windchill? Thanks :)
I've got windchill showing as the 'feels like' temperature, sorry for the confusion.

[]DLAST|CFeb 20, 2005 3:47AM
Some news:
A very very alpha version of 4x is available at http://plastic.xsintrk.net/mirc/weatherclient/4x/.

What works so far: all info including forecasts, english/metric/both units, proxy servers (with auth), all bot-related stuff, search by INTL station ID, UI for settings, and socket logging.
There's also a SIGNAL event when the info is retrieved, so you can make neat-o customized weather scripts if you choose. I included an example of how to show weather in popups using Virus-Z's notify popup addon.

What's not done: An editor for the bot's display, a pretty dialog for weather info, stuff like that.

Also, I'm not very good at UI so if anyone can make one better, gimmie it! You'll get credit!

Any other feature requests?

Text edited by author on Feb 20, 2005 @ 4:03AM


R1pl3yFeb 12, 2005 2:07PM
Excellent job plastic, and thank you for the timely updates, I appreciate your continuing work.

[]DLAST|CFeb 13, 2005 12:50AM
You are most welcome.

Help000Feb 10, 2005 2:24PM
Hi, i saw your 4x message on the main page, i was wondering if there could be a feature that we could set it so it shows temp in C and F. We use it ALL the time and would love this feature,
shame that we cant get international weather with the v3.1.2 patch :(

[]DLAST|CFeb 10, 2005 9:10PM
Internatonal weather seems to be working again. Try http://plastic.xsintrk.net/mirc/weatherclient/weatherclient3.2.zip.
As for your request, I'll keep it in mind :) Remember you can /weather -i/m to override the default settings for celcius/fahrenheit.

Text edited by author on Feb 10, 2005 @ 9:18PM


[]DLAST|CFeb 8, 2005 5:58PM
Recent changes to mobile.wunderground.com have broken this addon, with any luck I'll have it fixed within the next few days. International weather isn't even working on the site right now.

update:
I've made a patched version that seems to work, but not yet for INTL weather (I think that will change in a few days)
Check http://plastic.xsintrk.net/mirc/weatherclient/.

Text edited by author on Feb 8, 2005 @ 7:28PM


Gr4Jan 18, 2005 7:46AM
really, when ever someone looks up a city other than whats located in the united states or canada, they get a error, and have to go to a website, think this could be fixed?

[]DLAST|CJan 18, 2005 5:47PM
There shouldn't be an error, what cities are you searching? Try 'city, country', with a non-abbreviated country name.

Gr4Jan 28, 2005 8:29AM
im searching for singapore, singapore

usually errors out, but when you go to the link it will show it ....

[]DLAST|CJan 28, 2005 1:17PM
That will be fixed when I add forecasts. A lot of things have to be changed first.

Edit:
'Singapore, Payalebar' worked for me.

Text edited by author on Jan 28, 2005 @ 6:35PM


tuxedojerichoJan 24, 2005 10:21PM
First off, love the script.. Just one small error I noticed. When I was setting up the way the bot would display, I saw an option to display windcill <wchill>. However, when that is put into the code for the bot to display, all I get is WindChill: <wchill>

Is it just me, or was this an error overlooked?

[]DLAST|CJan 24, 2005 10:32PM
Yes it's an error, and will be removed in the next update (already removed in the beta).

TmaxJan 24, 2005 6:26PM
Well ladies and gents it seems to work just fine for the most part here although somethings need to be changed. For example 29.91 PSI would be nearly 2x the force of gravity. Not correct its 29.92 InHG or inches of murcury. The way it currently is, crushes people. Been using this for awhile and havent found a way to edit it out myself. Just curious if anyone else noticed tis. Also the lowercase names for everything is a bit annoying. Suggestions helpful, degrading comments welcome!

[]DLAST|CJan 24, 2005 8:28PM
You're right about the PSI, thanks - I'll get that fixed in the next update. I misunderstood the 'in' abbreviation on the site. Lowercase names for what? You can't change the case of the variables without editing the scriptfile, if that is what you mean. But the temp() cond() etc can be changed by the /woutput command.

coruptorJan 24, 2005 2:40PM
My timer doesnt seem to be working, no matter what i do... i get a msg in my status window that says /timer: timer wmaxcon not active. i set my count to 39. once it asked for the weather 39 times... it stopped dead
I cleard the %weather.53393095.nick lines out of the variable page... and it started working again
hope that helps

[]DLAST|CJan 24, 2005 3:49PM
Are you using mIRC 6.16?

RingRingJan 20, 2005 1:50PM
i understand that the maximum connections is 3 / min, but after the 3 tries, it doesnt work even after 3 hours..... it seems like its used up the 3 slots and forgot about the per min part...
it only works if i have unlimited but i would like to have it spam protected ...

[]DLAST|CJan 20, 2005 7:13PM
That is strange.. the timer must not be getting set. You can type /wpanic to reset connections, and they will work again.. that might fix it. If not, please email me, if you've got time to help me sort it out. Or let me know what server you use, and I'll stop by.

Text edited by author on Jan 20, 2005 @ 7:21PM


Al_Bundy33Jan 19, 2005 8:44PM
quote:
airtaz said:

Would be pretty cool...but when I use !weather zipcode it doesn't do anything. However if I use /weather zipcode it works. ??? "
Its doing the same thing to me too.... i have mirc 6.16 and 3.02 weather and its still not working right... works when you do /weather but not in open when ppl do the command and zip

~Phillip

[]DLAST|CJan 20, 2005 8:37AM
Works fine over here.

Help000Jan 19, 2005 11:18AM
thanks a lot for that! it worked :)
Another question please, is there a way so it can display both Fahrenheit and celsius temp?

[]DLAST|CJan 19, 2005 3:11PM
You can !weather -i 'search' or !weather -m 'search' to force english imperial or metric units, but you cannot show both at once, sorry.

Help000Jan 19, 2005 8:30AM
Hi, i was wondering if anyone knows how to get rid off the "attempting to retrieve weather for" bit?

[]DLAST|CJan 19, 2005 9:32AM
In the weatherclient.mrc, around lines 113/114, remove this:

if ($w.rsi) { $iif($w.rst,.notice,.msg) $($+(%,weather.,%w.ticks,.nick),2) $+ $iif($numtok($($+(%,weather.,%w.ticks,.nick),2),32) == 2,:) attempting to retrieve weather for $gettok(%wtemp,2-,32) $+ . }
if (!$w.rsi) { $iif($w.rst,notice,msg) $($+(%,weather.,%w.ticks,.nick),2) $+ $iif($numtok($($+(%,weather.,%w.ticks,.nick),2),32) == 2,:) attempting to retrieve weather for $gettok(%wtemp,2-,32) $+ . }

That should work fine.

Text edited by author on Jan 19, 2005 @ 9:33AM


RingRingJan 18, 2005 1:22PM
this is an awesome addon!!!
but i have a problem... !weather only works for first few tries, then it just ignores request from other users in the channel...
n e ideas?

[]DLAST|CJan 18, 2005 5:49PM
The default setting of /wmaxcon allows 3 requests per minute.

sniggleJan 11, 2005 3:07PM
upon loading this, i got this error:

* /writeini: insufficient parameters (line 85, weatherclient.mrc)

then, when typing /weather, i got:

* /02: weather insufficient parameters

this is with mirc 6.16.

[]DLAST|CJan 11, 2005 4:04PM
Damn, it's broken! I'll update later tonight, sorry.

You got '* /02..' because I missed a $color while switching to echo -c - another bug I wasn't aware of.

Text edited by author on Jan 11, 2005 @ 4:09PM


sniggleJan 11, 2005 6:32PM
3.0.1 seems to work fine. a quick thing to fix is that /wproxy is listed twice when you type /wconfig.

[]DLAST|CJan 11, 2005 4:33PM
Ok, some things were broken in the 3.0 release and I cannot update on this site for a few more days. In the meantime, Weather client is updated at http://plastic.xsintrk.net/mirc/weatherclient/. If you already have the addon installed, you may type /wupdate to download this update.

Text edited by author on Jan 11, 2005 @ 4:38PM


divDec 21, 2004 12:38PM
Just a request for a future version since I'm not experienced to code it myself =)
When my friend looks up 'Karlsruhe, Germany' there are two results. One with no temperature and one with.
Normally then this would return 'bad search param or no results'.
For a future version can you search all the sockread data for ° (the degree symbol) to check if the weather station is active,
then go to its URL 3 lines above and take that data?

Thanks =)

[]DLAST|CDec 21, 2004 6:02PM
I don't think it's possible the way the script is written now. But I'm about to be changing a lot of things I think (adding proxy support and stuff) and if I do that then I'll see if I can add your request. In the meantime, I think that's a bug with wunderground's page generator and I emailed them about it.

lilbpawNov 9, 2004 10:10AM
The script has always worked great for me. When i got the error message I checked for the a newer version. Installed now it is working again, however I end up with a lot of blank fields. Any chance this will get fixed or I can fix it myself. No, I am not a programmer or anything, but it works great and is easy to use.
Here is a sample of the output.

!weather 75201
<lilbpaw>attempting to retrieve weather for 75201.
<lilbpaw> From Dallas Love, Texas (7:53a Nov 9 04) temp(54f) cond() wind(ESE: 9mph) hu() dewpnt(45f) bp() clouds() vis(mi)

Not sure if this is the weather page or the script.. but I only get time and temp. Would like to have the other features as well.

Lilbpaw

[]DLAST|CNov 29, 2004 12:26PM
Please check the new Weather client FAQ, and send me a bug report.

lilbpawDec 14, 2004 12:42PM
Ok.. read the faq's really hard, which was difficult because I am not a programmer, just a user. Everything is back to normal now. It was of course user error.
What I am curious about now is this... I thought this script did International weather? Several users have tried weather outside the US and it doesn't work.. gets the bad param error.
While most of us are in US some are not. Maybe it no longer has this function or maybe We are typing in the wrong command ... btw.. we are doing !weather London, UK
and such.. is this correct or incorrect for international?


Thanks
Lilbpaw

[]DLAST|CDec 17, 2004 2:10AM
What was the user error, and how did you fix it?
International weather works fine.. try searching 'London, United Kingdom' instead of 'London, UK' - someone else had that problem with intl weather if you look wayyy down at the bottom of the forum.

[]DLAST|CSep 6, 2004 7:49AM
@terse:
it works perfectly for me, for both san diegos. sorry :) i don't know what the problem is. since you got the 'bad search' error it shouldn't have even displayed anything.
email me if you want to try to suss it out.

@Axis-
move to Delhi!

@FireWolfXion
http://plastic.xsintrk.net/mirc/weatherclient

Text edited by author on Sep 6, 2004 @ 7:52AM


lilbpawNov 9, 2004 10:11AM
The script has always worked great for me. When i got the error message I checked for the a newer version. Installed now it is working again, however I end up with a lot of blank fields. Any chance this will get fixed or I can fix it myself. No, I am not a programmer or anything, but it works great and is easy to use.
Here is a sample of the output.

!weather 75201
<lilbpaw>attempting to retrieve weather for 75201.
<lilbpaw> From Dallas Love, Texas (7:53a Nov 9 04) temp(54f) cond() wind(ESE: 9mph) hu() dewpnt(45f) bp() clouds() vis(mi)

Not sure if this is the weather page or the script.. but I only get time and temp. Would like to have the other features as well.

Lilbpaw

lilbpawNov 9, 2004 10:12AM
The script has always worked great for me. When i got the error message I checked for the a newer version. Installed now it is working again, however I end up with a lot of blank fields. Any chance this will get fixed or I can fix it myself. No, I am not a programmer or anything, but it works great and is easy to use.
Here is a sample of the output.

!weather 75201
<lilbpaw>attempting to retrieve weather for 75201.
<lilbpaw> From Dallas Love, Texas (7:53a Nov 9 04) temp(54f) cond() wind(ESE: 9mph) hu() dewpnt(45f) bp() clouds() vis(mi)

Not sure if this is the weather page or the script.. but I only get time and temp. Would like to have the other features as well.

Lilbpaw

terseSep 6, 2004 5:57AM
Using mIRC V. 6.16
Downloaded WeatherClient 2.7

This is the output I receive when I type "/weather"...

* /weather: From 72 (SanDiego,) temp(49%) cond(10.0) wind(29.90: mph) hu(52) dewpnt(North at 0) bp(Clear) clouds() vis(CLR: mi)
* /weather: bad search param or no results

As you can see the order of the fields and data retrieved is all mixed up. Please advise on the best way to fix this.

Thanks,
Dennis

Axis-Sep 6, 2004 1:50AM
it don't even have my city 'brantford, ontario' you should try getting the weater from http://sympatico.ca or something..

FireWolfXionSep 5, 2004 12:08PM
Seems to be a problem with the download file. (Most likely my browser is acting up...) Is there any other way to get this?

jagularAug 26, 2004 1:05PM
I am having problems getting the script to reply using notices. Using mirc 6.14 with weather script installed as required.

My options are set as follows:

Allow requests: yes
request trigger: !weather
connections: 3
use metrics: no
send reply as: notice
reply silently: no
support queries: no


Can someone help me please?
Thanks.

[]DLAST|CAug 31, 2004 5:57AM
quote:
jagular said:

Using mirc 6.14 with weather script installed as required.
ugh, if you'd looked at the readme, version history, or the updates tab here on ms.org;
quote:
I said:

You're going to need mIRC 6.16. I'm trying to update the whole script to 6.16 style.
Weather client will even remind you that you need 6.16, if you aren't using it. Also, make sure your users are sending /notice, since you've got the bot set to use notice instead of msg.

Text edited by author on Aug 31, 2004 @ 6:07AM


DeeperIDAug 21, 2004 4:45PM
LOL, great minds think alike. I was making a fix for this script and used the mobile brand as well since you were asking for scripting contributions on the weather page. Using the mobile brand takes up less bandwidth too, so good improvement at any rate. Thanks []DLAST|C, from all of X-Bots :)

[]DLAST|CAug 31, 2004 5:48AM
yw :)

coppercanAug 21, 2004 5:17AM
Thanks for the quick work updating the script. The users on our channels really like it and missed it the short time it was away.

Great little addon.

Scorpion44Aug 19, 2004 7:03PM
awesome, * /weather: there was a socket error (3) is what i am getting now :(

Text edited by author on Aug 19, 2004 @ 7:06PM


[]DLAST|CAug 19, 2004 7:44PM
oh, i haven't submitted an update to ms.org yet, just got my home copy working. i'll update here when i get everything working like before.

Scorpion44Aug 19, 2004 7:50PM
ok cool, btw your script kicks ass

[]DLAST|CAug 19, 2004 10:06PM
thanks :)

Scorpion44Aug 19, 2004 4:47PM
Do you know how long it will take you to build a new bot by any chance

Text edited by author on Aug 19, 2004 @ 4:52PM


[]DLAST|CAug 19, 2004 6:42PM
it's all fixed now except for cloud info.

[]DLAST|CAug 18, 2004 11:58PM
taking suggestions for a new site to steal INTL weather from...

i'd prefer a site with a simple page layout, it's easier to scrape.

Scorpion44Aug 19, 2004 4:46PM
How about http://www.weather.net/ ?

Scorpion44Aug 19, 2004 4:48PM
or weatherforyou.com

Text edited by author on Aug 19, 2004 @ 4:50PM


MajorGloryAug 18, 2004 8:20PM
This is a great script, It has been working fine untill today . Did weatherunderground change stuff around on the website all we get is * /weather: bad search param or no results with any zipe /location. Do you have a fix ??

[]DLAST|CAug 18, 2004 11:06PM
yes, the page has been changed, and it looks like the new one isn't as informative, so i'm going to try a different one. it's going to take awhile.

Text edited by author on Aug 18, 2004 @ 11:38PM


mr-gAug 10, 2004 7:25AM
Hi, Im trying to use the weather script with
!weather southampton england is this the correct syntax?
because it seems to work for !weather london england?

mr-gAug 10, 2004 7:53AM
ok found the problem
!weather southampton, united kingdom
works fine :)

SSJ4_Son_GokuAug 7, 2004 2:49PM
quote:
[]DLAST|C said:

The sockread string variable will cut itself at 920 characters.
If you care to know a var can hold up to 949 chars, but that probably doesn't make much of a difference.

[]DLAST|CAug 8, 2004 5:49AM
the problem wasn't with the var, but with $evalnext. 920 chars seems to be the highest you can go without getting an error.

airtazJun 2, 2003 9:59PM
Would be pretty cool...but when I use !weather zipcode it doesn't do anything. However if I use /weather zipcode it works. ???

MarshyTheKidJun 4, 2004 10:29PM
!weather is for other users. Its an 'ON TEXT' command, meaning when someone says !weather it will reply to it.



Create New Post

You must be logged in to post messages.